Author Topic:  Access to the path 'C:\Users\owner\Documents\My Games\TotalMiner\Temp' is denied  (Read 188 times)

0 Members and 1 Guest are viewing this topic.

hydrazombie

  • Fresh Meat
  • *
  • Posts: 0
    • View Profile
    • Awards
Total Miner. Please take a photo of this screen and post it on TotalMinerForums.net, so that we can fix it. Thank you.

System.IO.IOException: Access to the path 'C:\Users\owner\Documents\My Games\TotalMiner\Temp' is denied.
at System.IO.Directory.DeleteHelper(String fullPath, String userPath, Boolean recursive, Boolean throwOnTopLevelDirectoryNotFound)
at System.IO.Directory.Delete(String fullPath, String userPath, Boolean recursive, Boolean checkHost)
at StudioForge.TotalMiner.Globals2.LoadGlobalData()
at StudioForge.TotalMiner.Globals2.Initialize()
at StudioForge.TotalMiner.Screens.SplashScreen.LoadContent()
at StudioForge.Engine.GameState.ScreenManager.AddScreenInternal(GameScreen screen, Nullable`1 controllingPlayer)
at StudioForge.Engine.GameState.ScreenManager.AddScreen(GameScreen screen, Nullable`1 controllingPlayer)
at StudioForge.Engine.Game.GameWithScreenManager.Initialize()
at StudioForge.TotalMiner.TotalMinerGame.Initialize()
at Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
at StudioForge.Engine.Game.BaseGame.Run[T]()

bob

  • Administrator
  • Legendary Member
  • ******
  • Posts: 1507
  • Awards Award for outstanding excellence in the field of bob 5 years on site 4 years on site 3 years on site 2 years on site Was in the top 10 of the forum stats page as of 4/12/15 Members who have unlocked the robotic avatar 1 year on site Day 1 w/25+ posts (4/12/13)
    • View Profile
    • Awards
In the next update (a day or two from now), you'll be able to override the default save file location by adding a SaveRoot=xxx line into the game.ini file.

e.g.
SaveRoot=D:\SavedGames\TotalMinerData

To edit the game.ini file, right click Total Miner in your steam library, select Properties, Local Files, Browse Local Files.

hydrazombie

  • Fresh Meat
  • *
  • Posts: 0
    • View Profile
    • Awards
i have windows 10 64 bit and my antivirus is windows defender and it was stopping the game from running, i looked in the settings of windows defender and the controlled folder access was on ( i had this turned off before ) so i turned it off again and the game runs like it use to.

bob

  • Administrator
  • Legendary Member
  • ******
  • Posts: 1507
  • Awards Award for outstanding excellence in the field of bob 5 years on site 4 years on site 3 years on site 2 years on site Was in the top 10 of the forum stats page as of 4/12/15 Members who have unlocked the robotic avatar 1 year on site Day 1 w/25+ posts (4/12/13)
    • View Profile
    • Awards
i have windows 10 64 bit and my antivirus is windows defender and it was stopping the game from running, i looked in the settings of windows defender and the controlled folder access was on ( i had this turned off before ) so i turned it off again and the game runs like it use to.

Great. Thanks for the information. I'll keep this in mind for future reference in case somebody else has the same problem.