Author Topic:  Can't join worlds  (Read 222 times)

0 Members and 1 Guest are viewing this topic.

December Jim

  • Jr. Moderator
  • Elite Member
  • ******
  • Posts: 695
  • Awards 3 years on site+600 posts Site art contributions/TPs in-game/Contest winners I shot the sherriff 2 years on site+300 posts 1 year on site+100 posts
    • View Profile
    • Awards
  • Xbox: vJamie xD
  • Steam: Jimalene
Can't join worlds
« on: November 12, 2016, 08:29:27 AM »
It's only started to happen within the last week, but when I go to join people's worlds, it just kicks me back to the main menu where it says "press start". It happens with about 90% of worlds that I go to join and it's really annoying.. (People aren't literally kicking me from their worlds)

Even if the filesize thing at the right and side of the screen doesn't say Net: error, I still am not able to join most worlds.

I've refreshed the thing multiple times by pressing "Y"
I've went to the dashboard and reloaded the game up and it still doesn't let me join maps
I've turned my Xbox off and on multiple times
I've even reset my router and Internet in my house and it still doesn't let me join most maps.

Could anyone explain why this is happening because it's really annoying not being able to join people's worlds.


3rd in the world to unlock Demigods
Jr Moderator given on January 2nd 2017
YouTube: Jimalene
bob [31|Dec 12:56 PM]: Howdy Jimster